Changing 3g authentication CHAP to PAP - $100 dollar reward - Networking

There is a setting in Android>Settings>Wireless & networks>Mobile Networks>Access Point Names where a user can specify the Authentication type for connecting to 3g, my device allows you to choose either PAP, CHAP, BOTH or NONE.
HOWEVER, while the GUI shows PAP in the APN setting, if such is selected, the debugger shows that the device is trying to authenticate through CHAP. I have attached the log for you to see.
Please let me know how I can force through hardcoding the use of PAP to make the HSPA connection. Also, the DNSs are bogus, which also puzzles me.
There is $50 dollars as an incentive for whoever makes this happen.
01-19 22:18:07.665: DEBUG/vold(880): POWER_SUPPLY_NAME=ac
01-19 22:18:07.665: DEBUG/vold(880): POWER_SUPPLY_TYPE=Mains
01-19 22:18:07.665: DEBUG/vold(880): POWER_SUPPLY_ONLINE=1
01-19 22:18:33.425: DEBUG/NetworkLocationProvider(945): onDataConnectionStateChanged 10
01-19 22:18:33.465: DEBUG/MobileDataStateTracker(945): default Received state= DISCONNECTED, old= CONNECTING, reason= apnChanged, apnTypeList= *
01-19 22:18:33.465: DEBUG/NetworkStateTracker(945): setDetailed state, old =CONNECTING and new state=DISCONNECTED
01-19 22:18:33.465: DEBUG/ConnectivityService(945): ConnectivityChange for MOBILE: DISCONNECTED/DISCONNECTED
01-19 22:18:33.575: DEBUG/GpsLocationProvider(945): updateNetworkState available info: NetworkInfo: type: MOBILE[UNKNOWN], state: DISCONNECTED/DISCONNECTED, reason: apnChanged, extra: internet.movistar.mx, roaming: false, failover: false, isAvailable: false
01-19 22:18:33.575: DEBUG/GpsLocationProvider(945): NetworkThread wait for 9223372036854775807ms
01-19 22:18:33.595: INFO/MediaUploader(1135): No need to wake up
01-19 22:18:33.705: DEBUG/NetworkLocationProvider(945): onDataConnectionStateChanged 10
01-19 22:18:33.705: DEBUG/MobileDataStateTracker(945): default Received state= CONNECTING, old= DISCONNECTED, reason= (unspecified), apnTypeList= *
01-19 22:18:33.705: DEBUG/NetworkStateTracker(945): setDetailed state, old =DISCONNECTED and new state=CONNECTING
01-19 22:18:33.705: DEBUG/ConnectivityService(945): ConnectivityChange for MOBILE: CONNECTING/CONNECTING
01-19 22:18:35.335: INFO/pppd(1800): Serial connection established.
01-19 22:18:35.335: DEBUG/pppd(1800): using channel 7
01-19 22:18:35.355: DEBUG/vold(880): [UEVENT] Sq: 1439 S: net A: 0 P: /devices/virtual/net/ppp0
01-19 22:18:35.355: DEBUG/vold(880): DEVPATH=/devices/virtual/net/ppp0
01-19 22:18:35.355: DEBUG/vold(880): INTERFACE=ppp0
01-19 22:18:35.355: DEBUG/vold(880): IFINDEX=9
01-19 22:18:35.355: DEBUG/vold(880): No uevent handlers registered for 'net' subsystem
01-19 22:18:35.365: INFO/pppd(1800): Using interface ppp0
01-19 22:18:35.365: INFO/pppd(1800): Connect: ppp0 <--> /dev/ttyUSB0
01-19 22:18:36.375: DEBUG/pppd(1800): sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x1e53a172> <pcomp> <accomp>]
01-19 22:18:36.375: DEBUG/pppd(1800): rcvd [LCP ConfReq id=0x12 <asyncmap 0x0> <auth chap MD5> <magic 0xf88238> <pcomp> <accomp>]
01-19 22:18:36.375: DEBUG/pppd(1800): sent [LCP ConfAck id=0x12 <asyncmap 0x0> <auth chap MD5> <magic 0xf88238> <pcomp> <accomp>]
01-19 22:18:36.375: DEBUG/pppd(1800): rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x1e53a172> <pcomp> <accomp>]
01-19 22:18:36.385: DEBUG/pppd(1800): rcvd [LCP DiscReq id=0x13 magic=0xf88238]
01-19 22:18:36.385: DEBUG/pppd(1800): rcvd [CHAP Challenge id=0x1 <3a1477f1ae67d1c06633eef3a6ea709b>, name = "UMTS_CHAP_SRVR"]
01-19 22:18:36.385: DEBUG/pppd(1800): sent [CHAP Response id=0x1 <ebf1fb3e1003d2c0ea6e740043b60d28>, name = "CARD"]
01-19 22:18:36.395: DEBUG/pppd(1800): rcvd [CHAP Success id=0x1 ""]
01-19 22:18:36.395: INFO/pppd(1800): CHAP authentication succeeded
01-19 22:18:36.395: DEBUG/pppd(1800): sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
01-19 22:18:36.395: DEBUG/pppd(1800): sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
01-19 22:18:36.405: DEBUG/pppd(1800): rcvd [LCP ProtRej id=0x14 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
01-19 22:18:37.408: DEBUG/pppd(1800): rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
01-19 22:18:37.408: DEBUG/pppd(1800): sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14>]
01-19 22:18:37.645: INFO/pppd(1800): Modem hangup
01-19 22:18:37.645: INFO/pppd(1800): Connection terminated.
I'll Paypal you if you can solve this. It's a difficult thing for me to do, should be easy for you devs...

Why would you want the less secure approach?
I know nothing of deving but chap is more secure.
Maybe your network provider is forcing it.

ur network provider forces one of the two(if any) , if you leave the said form empty , the phone will use network default

SOLVED
Happy to help
Add the following new file to /etc/ppp/ ---- Set ALL Permissions to Read/Execute
filename: options
<start of file contents>
#/etc/ppp/options
#Require the peer to authenticate itself using PAP.
#+pap
#Don't agree to authenticate using PAP.
#-pap
#Require the peer to authenticate itself using CHAP [Cryptographic
#Handshake Authentication Protocol] authentication.
#+chap
#Don't agree to authenticate using CHAP.
-chap
#---<End of File>---
<end of file contents>
In root directory /etc/ppp/peers/ modify mcli-gsm
Add the line item at the bottom:
-chap
---- Confirm ALL Permissions set to Read/Execute
http://d-h.st/7F3 VirginBroadbandAndroidSupport.zip 8kb
File is for Virgin Mobile Australia Broadband Data Only as an example. You can change your APN settings as needed
The more user friendly installation howto is listed below: this howto requires the four files in the above zip file.
Using ES File explorer from play.google.com enable root explorer access, mout file system as writable, enable to root all enabelded. All Root settings are listed under ES explorer settings.
Before overwritting anyfile make a backup copy simply by changing the filename extension to .bak
Using ES file explorer navigate to /system/etc/ rename apns-conf.xml to apns-conf.bak
copy apns-conf.xml to /system/etc/ set permissions to rw- r-- r--
Using ES file explorer navigate to /system/etc/ppp/peers/ rename mcli-gsm to mcli-gsm.bak
copy mcli-gsm to /system/etc/ppp/peers/ set permissions to r-x r-x r-x
copy options to /system/etc/ppp/ set permissions to r-x r-x r-x
apples2apples said:
There is a setting in Android>Settings>Wireless & networks>Mobile Networks>Access Point Names where a user can specify the Authentication type for connecting to 3g, my device allows you to choose either PAP, CHAP, BOTH or NONE.
HOWEVER, while the GUI shows PAP in the APN setting, if such is selected, the debugger shows that the device is trying to authenticate through CHAP. I have attached the log for you to see.
Please let me know how I can force through hardcoding the use of PAP to make the HSPA connection. Also, the DNSs are bogus, which also puzzles me.
There is $50 dollars as an incentive for whoever makes this happen.
01-19 22:18:07.665: DEBUG/vold(880): POWER_SUPPLY_NAME=ac
01-19 22:18:07.665: DEBUG/vold(880): POWER_SUPPLY_TYPE=Mains
01-19 22:18:07.665: DEBUG/vold(880): POWER_SUPPLY_ONLINE=1
01-19 22:18:33.425: DEBUG/NetworkLocationProvider(945): onDataConnectionStateChanged 10
01-19 22:18:33.465: DEBUG/MobileDataStateTracker(945): default Received state= DISCONNECTED, old= CONNECTING, reason= apnChanged, apnTypeList= *
01-19 22:18:33.465: DEBUG/NetworkStateTracker(945): setDetailed state, old =CONNECTING and new state=DISCONNECTED
01-19 22:18:33.465: DEBUG/ConnectivityService(945): ConnectivityChange for MOBILE: DISCONNECTED/DISCONNECTED
01-19 22:18:33.575: DEBUG/GpsLocationProvider(945): updateNetworkState available info: NetworkInfo: type: MOBILE[UNKNOWN], state: DISCONNECTED/DISCONNECTED, reason: apnChanged, extra: internet.movistar.mx, roaming: false, failover: false, isAvailable: false
01-19 22:18:33.575: DEBUG/GpsLocationProvider(945): NetworkThread wait for 9223372036854775807ms
01-19 22:18:33.595: INFO/MediaUploader(1135): No need to wake up
01-19 22:18:33.705: DEBUG/NetworkLocationProvider(945): onDataConnectionStateChanged 10
01-19 22:18:33.705: DEBUG/MobileDataStateTracker(945): default Received state= CONNECTING, old= DISCONNECTED, reason= (unspecified), apnTypeList= *
01-19 22:18:33.705: DEBUG/NetworkStateTracker(945): setDetailed state, old =DISCONNECTED and new state=CONNECTING
01-19 22:18:33.705: DEBUG/ConnectivityService(945): ConnectivityChange for MOBILE: CONNECTING/CONNECTING
01-19 22:18:35.335: INFO/pppd(1800): Serial connection established.
01-19 22:18:35.335: DEBUG/pppd(1800): using channel 7
01-19 22:18:35.355: DEBUG/vold(880): [UEVENT] Sq: 1439 S: net A: 0 P: /devices/virtual/net/ppp0
01-19 22:18:35.355: DEBUG/vold(880): DEVPATH=/devices/virtual/net/ppp0
01-19 22:18:35.355: DEBUG/vold(880): INTERFACE=ppp0
01-19 22:18:35.355: DEBUG/vold(880): IFINDEX=9
01-19 22:18:35.355: DEBUG/vold(880): No uevent handlers registered for 'net' subsystem
01-19 22:18:35.365: INFO/pppd(1800): Using interface ppp0
01-19 22:18:35.365: INFO/pppd(1800): Connect: ppp0 <--> /dev/ttyUSB0
01-19 22:18:36.375: DEBUG/pppd(1800): sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x1e53a172> <pcomp> <accomp>]
01-19 22:18:36.375: DEBUG/pppd(1800): rcvd [LCP ConfReq id=0x12 <asyncmap 0x0> <auth chap MD5> <magic 0xf88238> <pcomp> <accomp>]
01-19 22:18:36.375: DEBUG/pppd(1800): sent [LCP ConfAck id=0x12 <asyncmap 0x0> <auth chap MD5> <magic 0xf88238> <pcomp> <accomp>]
01-19 22:18:36.375: DEBUG/pppd(1800): rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x1e53a172> <pcomp> <accomp>]
01-19 22:18:36.385: DEBUG/pppd(1800): rcvd [LCP DiscReq id=0x13 magic=0xf88238]
01-19 22:18:36.385: DEBUG/pppd(1800): rcvd [CHAP Challenge id=0x1 <3a1477f1ae67d1c06633eef3a6ea709b>, name = "UMTS_CHAP_SRVR"]
01-19 22:18:36.385: DEBUG/pppd(1800): sent [CHAP Response id=0x1 <ebf1fb3e1003d2c0ea6e740043b60d28>, name = "CARD"]
01-19 22:18:36.395: DEBUG/pppd(1800): rcvd [CHAP Success id=0x1 ""]
01-19 22:18:36.395: INFO/pppd(1800): CHAP authentication succeeded
01-19 22:18:36.395: DEBUG/pppd(1800): sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
01-19 22:18:36.395: DEBUG/pppd(1800): sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
01-19 22:18:36.405: DEBUG/pppd(1800): rcvd [LCP ProtRej id=0x14 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
01-19 22:18:37.408: DEBUG/pppd(1800): rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
01-19 22:18:37.408: DEBUG/pppd(1800): sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns3 10.11.12.14>]
01-19 22:18:37.645: INFO/pppd(1800): Modem hangup
01-19 22:18:37.645: INFO/pppd(1800): Connection terminated.
I'll Paypal you if you can solve this. It's a difficult thing for me to do, should be easy for you devs...
Click to expand...
Click to collapse

Related

Cisco VPN (ASA / PIX / IPSEC) and Winmo 6.1 - experts needed

Hi,
I'm trying to connect my new touch HD to the work cisco firewall. I've set it up as LDAP/IPSEC with a preshared key.
When I try and force it to connect it contacts the ASA, starts the handshake but I see this in the debugging VPN log:
Start of Handshake:
Code:
7 Nov 12 2008 15:36:23 713236 IP = 89.193.232.83, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 564
Point of issue (i think anyway)
Code:
7 Nov 12 2008 15:36:24 713906 IP = 89.193.232.83, computing NAT Discovery hash
4 Nov 12 2008 15:36:24 713903 Group = 89.193.232.83, IP = 89.193.232.83, Can't find a valid tunnel group, aborting...!
7 Nov 12 2008 15:36:24 715065 Group = 89.193.232.83, IP = 89.193.232.83, IKE MM Responder FSM error history (struct &0xd9298110) <state>, <event>: MM_DONE, EV_ERROR-->MM_BLD_MSG4, EV_GROUP_LOOKUP-->MM_BLD_MSG4, EV_TEST_CERT-->MM_BLD_MSG4, EV_BLD_MSG4-->MM_BLD_MSG4, EV_TEST_CRACK-->MM_BLD_MSG4, EV_SECRET_KEY_OK-->MM_BLD_MSG4, NullEvent-->MM_BLD_MSG4, EV_GEN_SECRET_KEY
7 Nov 12 2008 15:36:24 713906 Group = 89.193.232.83, IP = 89.193.232.83, IKE SA MM:d5e02623 terminating: flags 0x01000002, refcnt 0, tuncnt 0
7 Nov 12 2008 15:36:24 713906 Group = 89.193.232.83, IP = 89.193.232.83, sending delete/delete with reason message
Looking at the logs it at no point tries to auth with the username and password so it's a tunnelling issue.
Any super geeks about to help?
jon- said:
Hi,
I'm trying to connect my new touch HD to the work cisco firewall. I've set it up as LDAP/IPSEC with a preshared key.
When I try and force it to connect it contacts the ASA, starts the handshake but I see this in the debugging VPN log:
Start of Handshake:
Code:
7 Nov 12 2008 15:36:23 713236 IP = 89.193.232.83, IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 564
Point of issue (i think anyway)
Code:
7 Nov 12 2008 15:36:24 713906 IP = 89.193.232.83, computing NAT Discovery hash
4 Nov 12 2008 15:36:24 713903 Group = 89.193.232.83, IP = 89.193.232.83, Can't find a valid tunnel group, aborting...!
7 Nov 12 2008 15:36:24 715065 Group = 89.193.232.83, IP = 89.193.232.83, IKE MM Responder FSM error history (struct &0xd9298110) <state>, <event>: MM_DONE, EV_ERROR-->MM_BLD_MSG4, EV_GROUP_LOOKUP-->MM_BLD_MSG4, EV_TEST_CERT-->MM_BLD_MSG4, EV_BLD_MSG4-->MM_BLD_MSG4, EV_TEST_CRACK-->MM_BLD_MSG4, EV_SECRET_KEY_OK-->MM_BLD_MSG4, NullEvent-->MM_BLD_MSG4, EV_GEN_SECRET_KEY
7 Nov 12 2008 15:36:24 713906 Group = 89.193.232.83, IP = 89.193.232.83, IKE SA MM:d5e02623 terminating: flags 0x01000002, refcnt 0, tuncnt 0
7 Nov 12 2008 15:36:24 713906 Group = 89.193.232.83, IP = 89.193.232.83, sending delete/delete with reason message
Looking at the logs it at no point tries to auth with the username and password so it's a tunnelling issue.
Any super geeks about to help?
Click to expand...
Click to collapse
I have a working config from a Cisco PIX 501, however it can only run PIX OS 6.3(5) and not the newer 7.x or 8.x code the ASA's run so it's likely there are differences. Plus I am also using Digital Certificates as opposed to pre-shared keys, however that will only change the ISAKMP policy. I am also using MS IAS as the Radius server.
Code:
access-list l2tp permit udp host X.X.X.X any eq 1701
ip address outside X.X.X.X 255.255.255.252
ip local pool L2TP-IP-Pool-1 10.10.10.1-10.10.10.14 mask 255.255.255.240
aaa-server radius-authport 1812
aaa-server radius-acctport 1813
aaa-server RADIUS (inside) host 192.168.1.1 cisco-key timeout 5
aaa-server RADIUS (inside) host 192.168.2.1 cisco-key timeout 5
sysopt connection permit-l2tp
crypto ipsec transform-set l2tp esp-3des esp-sha-hmac
crypto ipsec transform-set l2tp mode transport
crypto ipsec security-association lifetime seconds 3600
crypto dynamic-map outside_dyn_map 10 set security-association lifetime seconds 28800 kilobytes 4608000
crypto dynamic-map dyna 20 match address l2tp
crypto dynamic-map dyna 20 set transform-set l2tp
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map mymap 10 ipsec-isakmp dynamic dyna
crypto map mymap client authentication RADIUS
crypto map mymap interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication rsa-sig
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
vpdn group L2TP-VPN accept dialin l2tp
vpdn group L2TP-VPN ppp authentication mschap
vpdn group L2TP-VPN client configuration address local L2TP-IP-Pool-1
vpdn group L2TP-VPN client configuration dns 192.168.1.50
vpdn group L2TP-VPN client authentication aaa RADIUS
vpdn group L2TP-VPN client accounting RADIUS
vpdn group L2TP-VPN l2tp tunnel hello 60
vpdn enable outside
I have changed the IP addresses I am using, plus I have ommited the PKI Certificate stuff. For PSK's you would need to change the ISAKMP policy.
HTH
Andy
So does this work with WM6.1 native IPSec stack?
There's a similar thread here:
http://forum.xda-developers.com/showthread.php?t=280565&page=2
Someone else stated they figured it out.
stepw said:
So does this work with WM6.1 native IPSec stack?
There's a similar thread here:
http://forum.xda-developers.com/showthread.php?t=280565&page=2
Someone else stated they figured it out.
Click to expand...
Click to collapse
Yes. I have tested this with Windows XP & 2003 as well as Windows Mobile 6.0 & 6.1. The default policies with Vista prevent this working 'out-of-the-box' due to AES being the minimum encryption the Vista VPN client will negotiate (ISAKMP). You can change this though, but it's a pain to do individually and is best pushed down via a GPO - or use an ASA or PIX 7.x or 8.x that supports AES ISAKMP policies.
Andy
ADB100, how is your Cisco firewall configured? I've gotten past phase 1 now but it's stalling at phase 2 as i can't get the client to request the correct policy, it keeps falling back to the default which I can't reconfigure as other policies inherit from it.
Starting to lose my patience, so close yet so far! WinMo6.1 and cisco ASA VPN still has ig issues and no one on the internet seems to know why.
ADB100 said:
Yes. I have tested this with Windows XP & 2003 as well as Windows Mobile 6.0 & 6.1. The default policies with Vista prevent this working 'out-of-the-box' due to AES being the minimum encryption the Vista VPN client will negotiate (ISAKMP). You can change this though, but it's a pain to do individually and is best pushed down via a GPO - or use an ASA or PIX 7.x or 8.x that supports AES ISAKMP policies.
Andy
Click to expand...
Click to collapse
I pretty much posted all the VPN stuff in my previous post. I could send you the entire config if you wish (with some bits scrubbed obviously). I may have an ASA at the end of next week to play around. I will be installing it at a customer site the following week so I should have enough time to test the VPN stuff out, if you can wait? (I'm a CCIE.....)
Cheers
Andy
So you did Andy, sorry I didn't link you to the earlier post. I will continue playing with the ASA today (as you might have guessed I'm not that up to speed with Cisco) and let you know if I get anything.
FWIW here is the drop out when it was failing at phase 1, i don't have the latest log to hand
Code:
IP = , Error: Unable to remove PeerTblEntry
IP = , Removing peer from peer table failed, no match!
IP = , sending delete/delete with reason message
IP = , IKE SA MM:bccde876 terminating: flags 0x01000002, refcnt 0, tuncnt 0
IP = , IKE MM Responder FSM error history (struct &0xd888df20) <state>, <event>: MM_DONE, EV_ERROR-->MM_WAIT_MSG3, EV_TIMEOUT-->MM_WAIT_MSG3, NullEvent-->MM_SND_MSG2, EV_SND_MSG-->MM_SND_MSG2, EV_START_TMR-->MM_SND_MSG2, EV_RESEND_MSG-->MM_WAIT_MSG3, EV_TIMEOUT-->MM_WAIT_MSG3, NullEvent
IP = , IKE_DECODE RESENDING Message (msgid=1100200) with payloads : HDR + UNKNOWN (218), *** ERROR *** + NONE (0) total length : 128
IP = , IKE_DECODE RESENDING Message (msgid=1100200) with payloads : HDR + UNKNOWN (218), *** ERROR *** + NONE (0) total length : 128
IP = , IKE_DECODE RESENDING Message (msgid=1100200) with payloads : HDR + UNKNOWN (218), *** ERROR *** + NONE (0) total length : 128
IP = , IKE_DECODE SENDING Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 124
IP = , constructing Fragmentation VID + extended capabilities payload
IP = , constructing NAT-Traversal VID ver 02 payload
IP = , constructing ISAKMP SA payload
IP = , IKE SA Proposal # 1, Transform # 8 acceptable Matches global IKE entry # 3
IP = , processing IKE SA payload
IP = , Received NAT-Traversal ver 02 VID
IP = , processing VID payload
IP = , Received Fragmentation VID
IP = , processing VID payload
IP = , processing VID payload
IP = , Oakley proposal is acceptable
IP = , processing SA payload
IP = , IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 544
IP = , Received encrypted packet with no matching SA, dropping
Ignoring msg to mark SA with dsID 151552 dead because SA deleted
IP = , IKE_DECODE SENDING Message (msgid=bbb6340d) with payloads : HDR + HASH (8) + DELETE (12) + NONE (0) total length : 76
Group = DefaultRAGroup, IP = , constructing qm hash payload
Group = DefaultRAGroup, IP = , constructing IKE delete payload
Group = DefaultRAGroup, IP = , constructing blank hash payload
Group = DefaultRAGroup, IP = , sending delete/delete with reason message
Group = DefaultRAGroup, IP = , IKE SA MM:78a1831c terminating: flags 0x01000002, refcnt 0, tuncnt 0
Group = DefaultRAGroup, IP = , IKE SA MM:78a1831c rcv'd Terminate: state MM_ACTIVE flags 0x00000042, refcnt 1, tuncnt 0
Group = DefaultRAGroup, IP = , Removing peer from correlator table failed, no match!
Group = DefaultRAGroup, IP = , sending delete/delete with reason message
Group = DefaultRAGroup, IP = , IKE QM Responder FSM error history (struct &0xd876e128) <state>, <event>: QM_DONE, EV_ERROR-->QM_BLD_MSG2, EV_NEGO_SA-->QM_BLD_MSG2, EV_IS_REKEY-->QM_BLD_MSG2, EV_CONFIRM_SA-->QM_BLD_MSG2, EV_PROC_MSG-->QM_BLD_MSG2, EV_HASH_OK-->QM_BLD_MSG2, NullEvent-->QM_BLD_MSG2, EV_COMP_HASH
Group = DefaultRAGroup, IP = , QM FSM error (P2 struct &0xd876e128, mess id 0x713438aa)!
IP = , IKE_DECODE SENDING Message (msgid=c1a6b7b3) with payloads : HDR + HASH (8) + NOTIFY (11) + NONE (0) total length : 80
Group = DefaultRAGroup, IP = , constructing qm hash payload
Group = DefaultRAGroup, IP = , constructing ipsec notify payload for msg id 713438aa
Group = DefaultRAGroup, IP = , constructing blank hash payload
Group = DefaultRAGroup, IP = , sending notify message
Group = DefaultRAGroup, IP = , All IPSec SA proposals found unacceptable!
Group = DefaultRAGroup, IP = , processing IPSec SA payload
Group = DefaultRAGroup, IP = , IKE Remote Peer configured for crypto map: outside-new_dyn_map
Group = DefaultRAGroup, IP = , Selecting only UDP-Encapsulated-Tunnel and UDP-Encapsulated-Transport modes defined by NAT-Traversal
Group = DefaultRAGroup, IP = , Selecting only UDP-Encapsulated-Tunnel and UDP-Encapsulated-Transport modes defined by NAT-Traversal
Group = DefaultRAGroup, IP = , Static Crypto Map check, map = outside-new_map, seq = 20, ACL does not match proxy IDs src: dst:213.122.163.115
Group = DefaultRAGroup, IP = , Static Crypto Map check, checking map = outside-new_map, seq = 20...
Group = DefaultRAGroup, IP = , QM IsRekeyed old sa not found by addr
Group = DefaultRAGroup, IP = , processing NAT-Original-Address payload
Group = DefaultRAGroup, IP = , L2TP/IPSec session detected.
Group = DefaultRAGroup, IP = , Received local Proxy Host data in ID Payload: Address 213.122.163.115, Protocol 17, Port 1701
Group = DefaultRAGroup, IP = , ID_IPV4_ADDR ID received
Group = DefaultRAGroup, IP = , processing ID payload
Group = DefaultRAGroup, IP = , Received remote Proxy Host FQDN in ID Payload: Host Name: HTC70 Address , Protocol 17, Port 1701
Group = DefaultRAGroup, IP = , ID_FQDN ID received, len 5
Group = DefaultRAGroup, IP = , processing ID payload
Group = DefaultRAGroup, IP = , processing nonce payload
Group = DefaultRAGroup, IP = , processing SA payload
Group = DefaultRAGroup, IP = , processing hash payload
IP = , IKE_DECODE RECEIVED Message (msgid=713438aa) with payloads : HDR + HASH (8) + SA (1) + NONCE (10) + ID (5) + ID (5) + NAT-OA (131) + NONE (0) total length : 293
IP = , IKE Responder starting QM: msg id = 713438aa
Group = DefaultRAGroup, IP = , Starting P1 rekey timer: 21600 seconds.
IP = , Keep-alives configured on but peer does not support keep-alives (type = None)
IP = , Keep-alive type for this connection: None
Group = DefaultRAGroup, IP = , PHASE 1 COMPLETED
IP = , IKE_DECODE SENDING Message (msgid=0) with payloads : HDR + ID (5) + HASH (8) + VENDOR (13) + NONE (0) total length : 96
Group = DefaultRAGroup, IP = , constructing dpd vid payload
Group = DefaultRAGroup, IP = , Computing hash for ISAKMP
Group = DefaultRAGroup, IP = , constructing hash payload
Group = DefaultRAGroup, IP = , constructing ID payload
Group = DefaultRAGroup, IP = , Freeing previously allocated memory for authorization-dn-attributes
IP = , Connection landed on tunnel_group DefaultRAGroup
Group = DefaultRAGroup, IP = , Automatic NAT Detection Status: Remote end IS behind a NAT device This end is NOT behind a NAT device
Group = DefaultRAGroup, IP = , Computing hash for ISAKMP
Group = DefaultRAGroup, IP = , processing hash payload
Group = DefaultRAGroup, IP = , ID_FQDN ID received, len 5
Group = DefaultRAGroup, IP = , processing ID payload
IP = , IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + ID (5) + HASH (8) + NONE (0) total length : 61
Group = DefaultRAGroup, IP = , P1 Retransmit msg dispatched to MM FSM
Group = DefaultRAGroup, IP = , Duplicate Phase 1 packet detected. Retransmitting last packet.
IP = , IKE_DECODE SENDING Message (msgid=0) with payloads : HDR + KE (4) + NONCE (10) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NAT-D (130) + NAT-D (130) + NONE (0) total length : 296
Group = DefaultRAGroup, IP = , Generating keys for Responder...
IP = , Connection landed on tunnel_group DefaultRAGroup
IP = , computing NAT Discovery hash
IP = , constructing NAT-Discovery payload
IP = , computing NAT Discovery hash
IP = , constructing NAT-Discovery payload
IP = , Send Altiga/Cisco VPN3000/Cisco ASA GW VID
IP = , constructing VID payload
IP = , Constructing ASA spoofing IOS Vendor ID payload (version: 1.0.0, capabilities: 20000001)
IP = , Send IOS VID
IP = , constructing xauth V6 VID payload
IP = , constructing Cisco Unity VID payload
IP = , constructing nonce payload
IP = , constructing ke payload
IP = , computing NAT Discovery hash
IP = , processing NAT-Discovery payload
IP = , computing NAT Discovery hash
IP = , processing NAT-Discovery payload
IP = , processing nonce payload
IP = , processing ISA_KE payload
IP = , processing ke payload
IP = , IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + KE (4) + NONCE (10) + NAT-D (130) + NAT-D (130) + NONE (0) total length : 224
IP = , IKE_DECODE RESENDING Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 124
IP = , P1 Retransmit msg dispatched to MM FSM
IP = , Duplicate Phase 1 packet detected. Retransmitting last packet.
IP = , IKE_DECODE RESENDING Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 124
IP = , P1 Retransmit msg dispatched to MM FSM
IP = , Duplicate Phase 1 packet detected. Retransmitting last packet.
IP = , IKE_DECODE SENDING Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 124
IP = , constructing Fragmentation VID + extended capabilities payload
IP = , constructing NAT-Traversal VID ver 02 payload
IP = , constructing ISAKMP SA payload
IP = , IKE SA Proposal # 1, Transform # 8 acceptable Matches global IKE entry # 3
IP = , processing IKE SA payload
IP = , processing VID payload
IP = , Received NAT-Traversal ver 02 VID
IP = , processing VID payload
IP = , Received Fragmentation VID
IP = , processing VID payload
IP = , processing VID payload
IP = , Oakley proposal is acceptable
IP = , processing SA payload
IP = , IKE_DECODE RECEIVED Message (msgid=0) with payloads : HDR + SA (1) + VENDOR (13) + VENDOR (13) + VENDOR (13) + VENDOR (13) + NONE (0) total length : 564
Thank you for your help thus far Andy.
ETA - I removed the timestamp to get within char limit, the oldest (first) message is at the bottom, newest (last) at top
Update - I've decided to go down the cert route as there's a working config from Andy above, however the Cisco ASA exports it's certificates in a format the winmo decive can't import! Any ideas?
jon- said:
Update - I've decided to go down the cert route as there's a working config from Andy above, however the Cisco ASA exports it's certificates in a format the winmo decive can't import! Any ideas?
Click to expand...
Click to collapse
OK, I have just got this working in my lab......
I have got a pretty basic config at the moment. I am using a pre-shared key for the ISAKMP phase I negotiation and local users. I have tested it with a Windows XP client and a couple of minutes ago with WM6.1 on my Kaiser. Both worked first time. I used the ASDM GUI to generate this configuration, I just attempted to match up the old PIX 6.3(5) config with the 7.2(4) code that is running on the new PIX.
Code:
ip local pool ip-pool 10.20.20.1-10.20.20.10 mask 255.255.255.240
!
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto dynamic-map inside_dyn_map 20 set transform-set TRANS_ESP_3DES_SHA
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 1
lifetime 86400
!
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
dns-server value 10.10.10.10
vpn-tunnel-protocol l2tp-ipsec
!
username cisco password cisco privilege 0
username cisco attributes
vpn-group-policy DefaultRAGroup
!
tunnel-group DefaultRAGroup general-attributes
address-pool ip-pool
default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key cisco
tunnel-group DefaultRAGroup ppp-attributes
authentication ms-chap-v2
I will do some more testing and get the authentication passed to an external Radius server as well as using RSA Certificates instead of a PSK.
HTH
Andy
Thanks Andy. Are you using the default policy for the devices? My problem seems to be I cant select a different group/tunnel/policy with winmo6.1 so it falls back to the default one which I can't configure to work with the device.
Yes its the default one (DefaultRAGroup), this is pretty much a vanilla PIX (it's not actually a real PIX its just an emulated one as well....). If you can let me have some of the bits of your config I can maybe test them here?
Andy
Here in lies my problem (i think), I can't use the default policy but can't force my phone to another policy.
Andy,
Been playing with Greenbow VPN client today after giving up on the built in one. No having much luck with that either, it seems to be trying to set up a lan to lan tunnel as well.
Here's the ASA config as requested
Code:
ip local pool Pool1 10.x.x.x-10.x.x.x mask 255.x.x.x
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map outside-new_dyn_map 20 set pfs
crypto dynamic-map outside-new_dyn_map 20 set transform-set ESP-3DES-SHA TRANS_ESP_3DES_SHA
crypto dynamic-map outside-new_dyn_map 40 set pfs
crypto dynamic-map outside-new_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 62.x.x.x
crypto map outside_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto map outside-new_map 20 match address outside-new_cryptomap_20
crypto map outside-new_map 20 set peer 62.x.x.x
crypto map outside-new_map 20 set transform-set ESP-DES-MD5
crypto map outside-new_map 65535 ipsec-isakmp dynamic outside-new_dyn_map
crypto map outside-new_map interface outside-new
crypto isakmp identity hostname
crypto isakmp enable outside
crypto isakmp enable outside-new
crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 40
authentication pre-share
encryption des
hash md5
group 1
lifetime 86400
crypto isakmp policy 50
authentication rsa-sig
encryption des
hash md5
group 1
lifetime 86400
group-policy DfltGrpPolicy attributes
banner value hispek.com vpn
vpn-simultaneous-logins 30
vpn-tunnel-protocol IPSec webvpn
ipsec-udp enable
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Internal_Nets
default-domain value hispek
nac-settings value DfltGrpPolicy-nac-framework-create
webvpn
svc keepalive none
svc dpd-interval client none
svc dpd-interval gateway none
customization value DfltCustomization
group-policy MobileVPN internal
group-policy MobileVPN attributes
dns-server value 10.x.x.x 10.x.x.x
vpn-tunnel-protocol IPSec l2tp-ipsec
username jjbmobile password * encrypted privilege 15
username jjbmobile attributes
vpn-tunnel-protocol IPSec l2tp-ipsec
service-type admin
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key M0b1132
tunnel-group DefaultRAGroup ppp-attributes
authentication ms-chap-v2
tunnel-group 62.x.x.x type ipsec-l2l
tunnel-group 62.x.x.x ipsec-attributes
pre-shared-key m0squito
tunnel-group MobileVPN type remote-access
tunnel-group MobileVPN general-attributes
address-pool Pool1
default-group-policy MobileVPN
tunnel-group MobileVPN ipsec-attributes
pre-shared-key JonsSillyNewPhone
tunnel-group MobileVPN ppp-attributes
authentication ms-chap-v2
!
class-map global-class
match default-inspection-traffic
class-map inside-class
match access-list inside_mpc
class-map outside-class
match access-list outside_mpc
!
Windows Mobile 6.1 with ASA 5510
ADB100 said:
I pretty much posted all the VPN stuff in my previous post. I could send you the entire config if you wish (with some bits scrubbed obviously). I may have an ASA at the end of next week to play around. I will be installing it at a customer site the following week so I should have enough time to test the VPN stuff out, if you can wait? (I'm a CCIE.....)
Cheers
Andy
Click to expand...
Click to collapse
Hi Andy,
I am a new user to the forum....I am trying to workout Windows Mobile 6.1 connect with ASA 5510 using IPSec, through available VPN client which allows L2TP/IPSec & PPTP.
I have seen your posts and found you got this working without any external VPN client....Would you be able to share that configuration with me???
Thanks,
nil3879
Too bad Bluefire Security went out-of-business because their WinMo VPN client worked really well with Cisco VPN 3000 series concentrator and PIX 500 series firewalls and I'm sure it would work with Cisco ASA as well. Tested using group password and AD authentication.

Help On Windows Mobile 6.1 Ip Forwarding

We are testing IP forwarding feature on windows mobile 6.1 platform. The scenario is as following:
169.254.19.49/16 169.254.54.165/16
+--------| a +--------+
| PC1 | ----------- | Mobile |
+--------+ +--------+
\ |
\ c b |
\ |
\ |
\ +---------+
\-------------- | PC2 |
169.254.160.194/16 +---------+
We setup an Wi-Fi ad-hoc network and 3 nodes involved. This is a full mesh network. There is a direct wireless link 'c' between PC1 and PC2 and we expect the IP packets path changed to be PC1--Mobile--PC2.
We enabled IP forwarding on the mobile phone and change PC1 and PC2's routing tables. But it seems IP forwarding does not work properly. We did 'ping 169.254.19.49' from PC2 and we did get the ICMP replies. While the packet sniffer shows that those replies are originated by the middle node (source IP is 169.254.54.165) and no packets are received by 169.254.19.49. How come the mobile phone take the responsibility to answer the ICMP reply for PC1 and it even does not check the reachability to PC1.It seems there is some kind of proxy running on the mobile? Any configuration we are missing?
The modifications to the devices are attached below:
PC1
----------------------------------------------------------------------------------------
IP: 169.254.19.49/16
Routing Table:
Network Destination Netmask Gateway Interface Metric
169.254.0.0 255.255.0.0 169.254.19.49 169.254.19.49 30
169.254.19.49 255.255.255.255 127.0.0.1 127.0.0.1 30
169.254.160.194 255.255.255.255 169.254.54.165 169.254.19.49 30
169.254.255.255 255.255.255.255 169.254.19.49 169.254.19.49 30
Basically, the routing setting implies that 'to 169.254.160.194, the next hop is 169.254.54.165'.
Registry setting:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableICMPRedirect = 0
The purpose is to ignore possible ICMP redirect message from the mobile phone which would change the route entry 169.254.160.194 back to a direct network route.
Mobile:
----------------------------------------------------------------------------------------
IP: 169.254. 54.165/16
Routing Table:
Network Destination Netmask Gateway Interface
Metric
169.254.0.0 255.255.0.0 169.254.160.194 0x3
25
169.254.19.49 255.255.255.255 169.254.54.165 0x3
30
169.254.54.165 255.255.255.255 127.0.0.1 0x3
30
169.254.160.194 255.255.255.255 169.254.54.165 0x3
30
169.254.255.255 255.255.255.255 169.254.2.1 0x30002
30
169.254.255.255 255.255.255.255 169.254.54.165 0x3
30
Registry setting:
HKEY_LOCAL_MACHINE\Comm\Tcpip\Parms\IpEnableRouter = 1
HKEY_LOCAL_MACHINE\Comm\Tcpip\Parms\EnableICMPRedirects = 0
PC2
----------------------------------------------------------------------------
------------
IP: 169.254.160.194/16
Routing Table:
Network Destination Netmask Gateway Interface
Metric
169.254.0.0 255.255.0.0 169.254.160.194 169.254.160.194
25
169.254.19.49 255.255.255.255 169.254.54.165 169.254.160.194
30
169.254.160.194 255.255.255.255 127.0.0.1 127.0.0.1
25
169.254.255.255 255.255.255.255 169.254.2.2 169.254.2.2
30
169.254.255.255 255.255.255.255 169.254.160.194 169.254.160.194
25
Basically, the routing setting implies that 'to 169.254.19.49, the next hop
is 169.254.54.165'.
Registry setting:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Enable
ICMPRedirect = 0
YOu shouldn't use 169.254 addressing.
169.254.0.0/16 is the "link local" block. It is allocated for communication between hosts on a single link.
Have a quick read on RFC 3330
something else in your network is probably interfering.
use 10.0.0.0/8 or perhaps 192.168.0.0/16 or 172.16.0.0/12 as these are set aside for private networking addresses.
thank you very much
farkah said:
YOu shouldn't use 169.254 addressing.
169.254.0.0/16 is the "link local" block. It is allocated for communication between hosts on a single link.
Have a quick read on RFC 3330
something else in your network is probably interfering.
use 10.0.0.0/8 or perhaps 192.168.0.0/16 or 172.16.0.0/12 as these are set aside for private networking addresses.
Click to expand...
Click to collapse
Thank you Very Much!!!! I have solve this problem!!!!

O2 MMS Problem

I'm having issues sending & receiving MMS messages. The data connection works fine for browsing, and the APN settings are the ones from the O2 website (although I've tried several combinations from Google).
Same problem on both PPP and RMNet on michy's r11 and PPP on hastarin 7.2, can't figure it out. I've spent hours on Google and have search XDA, and can't get anywhere.
I've even tried using the Google DNS & O2 DNS servers to no avail.
I've included a logcat of what happens when I try to send an MMS in case it helps.
Does anyone have any ideas? I'm stumped.
We have 2 HD2s on O2, happens on both.
MMS works fine in WinMo.
WinMo: O2 Stock 1.72
Radio 2.12 & 2.15
Android: Bangsters 1.4 & 1.5
Kernel: michy's r11 and hastarin #7.2
Code:
I/pppd ( 2973): PAP authentication succeeded
D/MobileDataStateTracker( 304): mms Received state= CONNECTED, old= CONNECTING, reason= apnSwitched, apnTypeList= mms
D/NetworkStateTracker( 304): setDetailed state, old =CONNECTING and new state=CONNECTED
D/ConnectivityService( 304): ConnectivityChange for mobile_mms: CONNECTED/CONNECTED
V/NetworkStateTracker( 304): Setting TCP values: [4093,26280,35040,4096,16384,35040] which comes from [net.tcp.buffersize.edge]
D/NetworkLocationProvider( 304): onDataConnectionStateChanged 1
D/NetworkStateTracker( 304): addPrivateDnsRoutes for Mobile data state: CONNECTED(ppp0) - mPrivateDnsRouteSet = false
D/NetworkStateTracker( 304): adding 193.113.200.200 (-926387775)
D/NetworkStateTracker( 304): adding 193.113.200.201 (-909610559)
D/Tethering( 304): Tethering got CONNECTIVITY_ACTION
D/Tethering( 304): MasterInitialState.processMessage what=3
E/HierarchicalStateMachine( 304): TetherMaster - unhandledMessage: msg.what=3
D/GpsLocationProvider( 304): updateNetworkState available info: NetworkInfo: type: mobile_mms[EDGE], state: CONNECTED/CONNECTED, reason: apnSwitched, extra: mobile.o2.co.uk, roaming: false, failover: false, isAvailable: true
V/NetworkChange( 767): Received network change notification
D/NetworkLocationProvider( 304): updateNetworkState(): Updating network state to 2
D/ConnectivityService( 304): startUsingNetworkFeature for net 0: enableMMS
D/ConnectivityService( 304): getMobileDataEnabled returning true
D/ConnectivityService( 304): special network already active
I/GTalkService( 440): [ServiceAutoStarter] --- connectivity changed
I/GTalkService( 440): [ServiceAutoStarter] --- start GTalk service ---
I/MediaUploader( 731): No need to wake up
E/SendTransaction( 596): java.io.IOException: Cannot establish route for http://mmsc.mms.o2.co.uk: Unknown host
E/SendTransaction( 596): at com.android.mms.transaction.Transaction.ensureRouteToHost(Transaction.java:210)
E/SendTransaction( 596): at com.android.mms.transaction.Transaction.sendPdu(Transaction.java:165)
E/SendTransaction( 596): at com.android.mms.transaction.Transaction.sendPdu(Transaction.java:150)
E/SendTransaction( 596): at com.android.mms.transaction.SendTransaction.run(SendTransaction.java:118)
E/SendTransaction( 596): at java.lang.Thread.run(Thread.java:1096)
E/SendTransaction( 596): Delivery failed.
bump bump. Same problem here for me
contract or payg ?
contract.......................
In your MMS APN settings is the http://mmsc* server information in the SERVER or MMS SERVER slot?
dkl_uk said:
In your MMS APN settings is the http://mmsc* server information in the SERVER or MMS SERVER slot?
Click to expand...
Click to collapse
Tried in each and both
optiknerv said:
Tried in each and both
Click to expand...
Click to collapse
Well it definitely shouldn't be in the SERVER slot, that's part of your issue and you will receive errors regarding the lack of connection. It's trying to connect to something it's not supposed to want to connect to.
You have a choice of the following:
Data Bearer:
GPRS
Access Point Node (APN):
wap.o2.co.uk (contract)
payandgo.o2.co.uk (PAYG)
User ID:
o2wap (contract)
payandgo (PAYG)
Password:
password
Authentication
Normal
Gateway
193.113.200.195
MMS Message Server
http://mmsc.mms.o2.co.uk:8002
ENSURE there is a tick only in the MMS box.
I have tried to setup MMS in my network settings and failed, although it can be done. You should end up with two APN's, one is "default,supl" and the other is "mms".
dkl_uk said:
Well it definitely shouldn't be in the SERVER slot, that's part of your issue and you will receive errors regarding the lack of connection. It's trying to connect to something it's not supposed to want to connect to.
You have a choice of the following:
Data Bearer:
GPRS
Access Point Node (APN):
wap.o2.co.uk (contract)
payandgo.o2.co.uk (PAYG)
User ID:
o2wap (contract)
payandgo (PAYG)
Password:
password
Authentication
Normal
Gateway
193.113.200.195
MMS Message Server
http://mmsc.mms.o2.co.uk:8002
ENSURE there is a tick only in the MMS box.
I have tried to setup MMS in my network settings and failed, although it can be done. You should end up with two APN's, one is "default,supl" and the other is "mms".
Click to expand...
Click to collapse
I don't get a failed connection error. In fact I note that when I click send it disconnects from data connection then reconnects (i presume to the mms settings) it seems to show data upload and download but after a couple of minutes I get a "failed to send message after multiple attempts error"
It's just a wild guess, but I had problems with sending MMSes (while being sure that all carrier APN's settings were correct), when MMS Size setting was set to higher values than 300 KB. Although my problems were only with sending MMSes - I could receive them without any problems.
adecostres said:
It's just a wild guess, but I had problems with sending MMSes (while being sure that all carrier APN's settings were correct), when MMS Size setting was set to higher values than 300 KB. Although my problems were only with sending MMSes - I could receive them without any problems.
Click to expand...
Click to collapse
Seems this was the problem. Cheers.

BlueTooth Suddenly Stopped Working - EPIC 4g

I am not sure what happened. My Bluetooth was working fine. All of a sudden it stopped. When I press the bluetooth icon, i see that it is trying to turn on, but never goes fully "green".
I have done application updates and have rooted my phone and thats it. No special kernel, nothing else thats fancy. Here is an 'adb logcat' of what happens when I try to launch bluetooth:
Code:
I/BluetoothAdapter( 2229): ***** enable
I/BluetoothService( 2229): ***** enable
I/bluedroid( 2229): bt_enable
I/bluedroid( 2229): BTOFF_FMOFF_handling
I/bluedroid( 2229): BTOFF_FMOFF_handling : receiving BT_ON
I/bluedroid( 2229): Starting daemons...
I/bluedroid( 2229): Starting btld...
D/BTL-SERVER(16100): in set_aid_and_cap() pid:16100
V/BluetoothEventRedirector( 6906): Received android.bluetooth.adapter.action.STATE_CHANGED
D/BTL-SERVER(16100): out set_aid_and_cap() pid:16100
V/BTL_CFG (16100): btl_cfg_get_btld_status: service.brcm.bt.btld=0
E/BTL-SERVER(16100): BTLD starting...
E/BTL-SERVER(16100): main: main :: BTLD starting
V/BTL_CFG (16100): btl_cfg_set_btld_status: service.brcm.bt.btld=1, ret=0
V/BTL_CFG (16100): btld_cfg_btld_pid : service.brcm.bt.btld_pid = 16100
V/BTL_CFG (16100): btl_cfg_set_btld_pid success : service.brcm.bt.btld_pid = 16100, ret = 0
I/BTL-SERVER(16100): BTE version BCM1200_MI_10.3.16.26
I/BTL-SERVER(16100): btld version BTL-ANDROID_PI_2.0.52 starting...
I/BTL-SERVER(16100): btla version BTL-ANDROID-Victory-R11-Sep 13 2010 ###########
I/BTL-SERVER(16100): Build time: Sep 13 2010 18:32:14
I/BTL-SERVER(16100): BTLD_OPTION_LPM_ENABLED: i=0x6 argc=0x7 lpm_enabled=1
I/BTL_CFG (16100): btl_cfg_get_bdaddr: BDA=F49F5497C7EE
E/BTL_CFG (16100): WARNING: [service.brcm.bt.patchfile] property_get failed (0)
E/BTL_CFG (16100): WARNING: [service.brcm.bt.3way_support] property_get failed (0)
E/BTL_CFG (16100): WARNING: [service.brcm.bt.bt_wake_polar] property_get failed (0)
I/BTL_CFG (16100): btl_cfg_get_lpm_params: service.brcm.bt.bt_wake_polar=1
E/BTL_CFG (16100): WARNING: [service.brcm.bt.host_wake_polar] property_get failed (0)
I/BTL_CFG (16100): btl_cfg_get_lpm_params: service.brcm.bt.host_wake_polar=1
E/BTL_CFG (16100): WARNING: [service.brcm.bt.pcm_clk] property_get failed (0)
E/BTL_CFG (16100): WARNING: [service.brcm.bt.pcm_ms_role] property_get failed (0)
I/BTL_CFG (16100): btl_cfg_get_contacts_db: service.brcm.bt.contacts_db=/data/data/com.android.providers.contacts/databases/contacts2.db
I/USERIAL_LINUX(16100): USERIAL_Init
I/USERIAL_LINUX(16100): USERIAL_Open
I/USERIAL_LINUX(16100): USERIAL_Open opening /dev/s3c2410_serial0
D/USERIAL_LINUX(16100): sock = 6
I/USERIAL_LINUX(16100): Leaving USERIAL_Open
E/BTL_CFG (16100): WARNING: [service.brcm.bt.TRC_BTAPP] property_get failed (0)
D/BTLD (16100): [bttrc] using compile default trace settings
D/USERIAL_LINUX(16100): USERIAL_Ioctl: Received USERIAL_OP_BAUD_WR ioctl
I/USERIAL_LINUX(16100): USERIAL_Ioctl: Received USERIAL_OP_BAUD_WR ioctl 14
I/USERIAL_LINUX(16100): userial_change_rate: Closing UART Port
D/USERIAL_LINUX(16100): socket signaled
D/USERIAL_LINUX(16100): socket signal reseted
W/USERIAL_LINUX(16100): my_read return size <=0:-1, exiting userial_read_thread
I/USERIAL_LINUX(16100): USERIAL_Close
D/USERIAL_LINUX(16100): userial_change_rate: Attempting to reopen the UART Port at 0x002dc6c0
I/USERIAL_LINUX(16100): userial_change_rate: Attempting to reopen the UART Port at 3000000
I/USERIAL_LINUX(16100): USERIAL_Open
I/USERIAL_LINUX(16100): USERIAL_Open opening /dev/s3c2410_serial0
D/USERIAL_LINUX(16100): sock = 6
I/USERIAL_LINUX(16100): Leaving USERIAL_Open
I/BTL-SERVER(16100): Found patchfile: /system/bin/BCM4329B1_002.002.023.0417.0435.hcd
I/BTL-SERVER(16100): bte_main_rln_cplt: Downloading patchfile /system/bin/BCM4329B1_002.002.023.0417.0435.hcd
I/BTLD (16100): BCM2045_PRM_Init
I/BTLD (16100): Minidrv download completed
E/BTLD (16100): [hcis] Unknown HCI message type drop this byte 0x34
E/BTLD (16100): [hcis] Unknown HCI message type drop this byte 0x31
I/BTLD (16100): Launch RAM successful
D/USERIAL_LINUX(16100): USERIAL_Ioctl: Received USERIAL_OP_BAUD_WR ioctl
I/USERIAL_LINUX(16100): USERIAL_Ioctl: Received USERIAL_OP_BAUD_WR ioctl 7
I/USERIAL_LINUX(16100): userial_change_rate: Closing UART Port
D/USERIAL_LINUX(16100): socket signaled
D/USERIAL_LINUX(16100): socket signal reseted
W/USERIAL_LINUX(16100): my_read return size <=0:-1, exiting userial_read_thread
I/USERIAL_LINUX(16100): USERIAL_Close
D/USERIAL_LINUX(16100): userial_change_rate: Attempting to reopen the UART Port at 0x0001c200
I/USERIAL_LINUX(16100): userial_change_rate: Attempting to reopen the UART Port at 115200
I/USERIAL_LINUX(16100): USERIAL_Open
I/USERIAL_LINUX(16100): USERIAL_Open opening /dev/s3c2410_serial0
D/USERIAL_LINUX(16100): sock = 6
I/USERIAL_LINUX(16100): Leaving USERIAL_Open
D/USERIAL_LINUX(16100): USERIAL_Ioctl: Received USERIAL_OP_BAUD_WR ioctl
I/USERIAL_LINUX(16100): USERIAL_Ioctl: Received USERIAL_OP_BAUD_WR ioctl 14
I/USERIAL_LINUX(16100): userial_change_rate: Closing UART Port
D/USERIAL_LINUX(16100): socket signaled
D/USERIAL_LINUX(16100): socket signal reseted
W/USERIAL_LINUX(16100): my_read return size <=0:-1, exiting userial_read_thread
I/USERIAL_LINUX(16100): USERIAL_Close
D/USERIAL_LINUX(16100): userial_change_rate: Attempting to reopen the UART Port at 0x002dc6c0
I/USERIAL_LINUX(16100): userial_change_rate: Attempting to reopen the UART Port at 3000000
I/USERIAL_LINUX(16100): USERIAL_Open
I/USERIAL_LINUX(16100): USERIAL_Open opening /dev/s3c2410_serial0
D/USERIAL_LINUX(16100): sock = 6
I/USERIAL_LINUX(16100): Leaving USERIAL_Open
I/BTL-SERVER(16100): Setting local bd addr to F4:9F:54:97:C7:EE
I/BTL-IFS (16100): BTL_IF_RegisterSubSystem: Registered subsystem [DTUN]
W/BTLD (16100): BTAPP_enable_bta(): unsupported id: 28
I/BTL-IFS (16100): BTL_IF_RegisterSubSystem: Registered subsystem [TEST]
I/BTL_CFG (16100): btl_cfg_get_btport_redirection_enable: service.brcm.bt.btport_redir_on=
I/BTL-IFS (16100): BTL_IF_RegisterSubSystem: Registered subsystem [DUN]
I/BTL-IFS (16100): BTL_IF_RegisterSubSystem: Registered subsystem [SPP]
I/BTL-IFS (16100): BTL_IF_RegisterSubSystem: Registered subsystem [AG]
I/BTL-IFS (16100): BTL_IF_RegisterSubSystem: Registered subsystem [SCO]
W/BTLD (16100): BTAPP_enable_bta(): unsupported id: 20
I/BTL-IFS (16100): BTL_IF_RegisterSubSystem: Registered subsystem [PBS]
I/BTL-IFS (16100): BTL_IF_RegisterSubSystemMultiClnt: Registered subsystem [BTS]
I/bluedroid( 2229): BTLD start retry count 130/130
E/bluedroid( 2229): btld start timed out
I/bluedroid( 2229): New state is BTON_FMOFF_handling
D/BluetoothService( 2229): bt EnableThread giving up
I/bluedroid( 2229): bt_disable
I/bluedroid( 2229): BTON_FMOFF_handling
I/bluedroid( 2229): BTON_FMOFF_handling : receiving BT_OFF
I/bluedroid( 2229): Stopping daemons...
I/bluedroid( 2229): Stopping bluetoothd...
I/bluedroid( 2229): Stopping btld...
I/bluedroid( 2229): Wait until all daemons are stopped, or timed out...
I/bluedroid( 2229): bluetoothd has stopped
W/bluedroid( 2229): Daemon stop waiting count 1/130
I/bluedroid( 2229): Stopping daemons... Done!
I/bluedroid( 2229): New state is BTOFF_FMOFF_handling
W/BTLD (16100): L2CAP - PSM: 0x0019 not found for deregistration
W/BTLD (16100): L2CAP - PSM: 0x0017 not found for deregistration
V/BluetoothEventRedirector( 6906): Received android.bluetooth.adapter.action.STATE_CHANGED
I/BTL-IFS (16100): main_server_thread: main_server_thread: bt shutdown while waiting for select
I/BTL-IFS (16100): close_all_open_sockets: Closing all open sockets
I/BTL-IFS (16100): main_server_thread: @*@*@*@*@*@*@*@*@*@*@*@*@* main_server_thread - close(12)
I/BTL-IFS (16100): main_server_thread: BTL-IF server thread terminating...
I/BTL-IFS (16100): BTL_IF_ServerShutdown: BTL-IF Server shutting down...
I/BTL-IFS (16100): BTL_IF_ServerShutdown: BTL-IF Server shutdown complete.
I/BTL-IFS (16100): BTL_IF_UnregisterSubSystem: Unregistered subsystem [DTUN]
D/USERIAL_LINUX(16100): USERIAL_Ioctl: Received USERIAL_OP_BAUD_WR ioctl
I/USERIAL_LINUX(16100): USERIAL_Ioctl: Received USERIAL_OP_BAUD_WR ioctl 7
I/USERIAL_LINUX(16100): userial_change_rate: Closing UART Port
D/USERIAL_LINUX(16100): socket signaled
D/USERIAL_LINUX(16100): socket signal reseted
W/USERIAL_LINUX(16100): my_read return size <=0:-1, exiting userial_read_thread
I/USERIAL_LINUX(16100): USERIAL_Close
D/USERIAL_LINUX(16100): userial_change_rate: Attempting to reopen the UART Port at 0x0001c200
I/USERIAL_LINUX(16100): userial_change_rate: Attempting to reopen the UART Port at 115200
I/USERIAL_LINUX(16100): USERIAL_Open
I/USERIAL_LINUX(16100): USERIAL_Open opening /dev/s3c2410_serial0
D/USERIAL_LINUX(16100): sock = 6
I/USERIAL_LINUX(16100): Leaving USERIAL_Open
D/USERIAL_LINUX(16100): socket signaled
D/USERIAL_LINUX(16100): socket signal reseted
W/USERIAL_LINUX(16100): my_read return size <=0:-1, exiting userial_read_thread
I/USERIAL_LINUX(16100): USERIAL_Close
V/BTL_CFG (16100): btld_cfg_btld_pid : service.brcm.bt.btld_pid = 0
V/BTL_CFG (16100): btl_cfg_set_btld_pid success : service.brcm.bt.btld_pid = 0, ret = 0
V/BTL_CFG (16100): btl_cfg_set_btld_status: service.brcm.bt.btld=0, ret=0
I/BTL-SERVER(16100): ### Target baudrate is reset, now exit btld ###
So anyone know what gives. Looking at the logs it seems that it can't initialize a setting or sumthin'
Have you tried deleting/forgeting your headset and repairing the device? Sometimes simple is best.
I have no paired devices.
Sent from my Epic xda style. http://zedros.com
I still havent been able to get my bluetooth working. Anyone else having a problem with this? My bluetooth just 'stopped' working. I hit the bluetooth icon, it seems like it is beginning to launch, but then nothing happens. No freezes, lockups, etc... It just goes back to its original state like i never hit the bluetooth button to begin with. This is getting on my nerves as I like to transfer files via bluetooth when I am not connected via USB.
Same Problem
Yes, I'm having the same problem on a Samsung Fascinate, running 2.1
I am positive that, based on the log files, ... that this is a permissions issue. I am hoping that moving to 2.2 will fix it. Sprint/Samsung give me my update. I don't **** with HTC anymore because of the video hardware fiasco they had with the Kaiser. Don't b next. Lols
Sent from my SPH-D700 using XDA App
May b a missing configuration file as well.
Sent from my SPH-D700 using XDA App
Anyone figure this out? I am having this problem, too.
Happened to me too after 1-click root w/CWM (and a couple of other updates). Restoring initial backup after one-click root and clockwork did NOT fix this. I had to wipe and re-install DI18 stock rom in order to get bluetooth working again. Please note that I did not use any dev tools to troubleshoot.
It broke somewhere in this process:
1. 1-click root w/Clockwork
1a. backed up, restoring that backup with clockwork still had the problem, but I didn't originally notice the problem until later.
2. Tried to follow instructions for 2nd full root, but was getting permissions errors. Still had root, so I continued (never got this to work).
3. Installed ROM Manager
3a. ROM Manager for some reason was booting into stock recovery and not CWM. Could still get to CWM via Vol-down+shutter+power.
4. Installed Mobile AP mod.
All of this was on Saturday. didn't try bluetooth until monday when I discovered it was pooched - Bluetooth wouldn't turn on, either through touchwiz, or settings. It would look like it was turning on ('On', but grey, then turn off again).
Flashed back to stock DI18 and bluetooth is working again.

Cannot make outgoing call on builded ROM

Hi
I've build new ROM from CM6 Sources and everything works except making outgoing call (I can answer a incoming call). Calling stuck on "Dialing", when I end call, it stuck on "Hanging up", and I can't exit this.
This is log from adb logcat (from booting to make call):
Code:
E/GlsClient-query( 1652): at aB.f.run(Unknown Source)
E/GlsClient-query( 1652): at aH.d.run(Unknown Source)
I/BootReceiver( 1666): Got intent with action android.intent.action.MEDIA_MOUNTE
D
I/ActivityManager( 1246): Start proc com.google.android.apps.uploader for broadc
ast com.google.android.apps.uploader/.ConnectivityBroadcastReceiver: pid=1687 ui
d=10051 gids={3003}
D/MediaScannerService( 1541): start scanning volume external
V/MediaProvider( 1541): /mnt/sdcard volume ID: 996875024
I/ActivityThread( 1687): Publishing provider com.google.android.apps.uploader: c
om.google.android.apps.uploader.UploadsContentProvider
I/ActivityThread( 1687): Publishing provider com.google.photos.provider.Album: c
om.google.android.apps.uploader.clients.picasa.AlbumProvider
D/MediaUploader( 1687): UploaderApplication.onCreate
D/MediaUploader( 1687): nonWifiLimit=20971520, default=20971520
I/MediaUploader( 1687): No need to wake up
I/BootReceiver( 1666): Got intent with action android.intent.action.MEDIA_SCANNE
R_FINISHED
V/MediaProvider( 1541): deleting obsolete album art /mnt/sdcard/Android/data/com
.android.providers.media/albumthumbs/RockOnNg
V/MediaProvider( 1541): Attached volume: external
D/MediaScanner( 1541): prescan time: 54ms
D/MediaScanner( 1541): scan time: 945ms
D/MediaScanner( 1541): postscan time: 0ms
D/MediaScanner( 1541): total time: 999ms
I/BootReceiver( 1666): Got intent with action android.intent.action.MEDIA_SCANNE
R_FINISHED
D/MediaScannerService( 1541): done scanning volume external
I/CacheService( 1666): Starting CacheService
I/CacheService( 1666): Preparing DiskCache for all thumbnails.
D/dalvikvm( 1666): GC_FOR_MALLOC freed 7867 objects / 435808 bytes in 61ms
I/CacheService( 1666): DiskCache ready for all thumbnails.
D/WifiService( 1246): ACTION_BATTERY_CHANGED pluggedType: 2
D/VoiceDialerReceiver( 1609): onReceive Intent { act=android.intent.action.PACKA
GE_CHANGED dat=package:com.android.stk flg=0x10000000 cmp=com.android.voicediale
r/.VoiceDialerReceiver (has extras) }
V/RecognizerEngine( 1609): deleteCachedGrammarFiles /data/data/com.android.voice
dialer/files/openentries.txt
D/KeyguardViewMediator( 1246): pokeWakelock(5000)
D/dalvikvm( 1246): GC_FOR_MALLOC freed 13710 objects / 734544 bytes in 131ms
D/KeyguardViewMediator( 1246): pokeWakelock(5000)
D/SettingsAppWidgetProvider( 1388): Widget is from a previous version... Let's u
pdate
D/SettingsAppWidgetProvider( 1388): No instances yet... Wait for at least one in
stance to exist before adding global settings
D/ConnectivityService( 1246): getMobileDataEnabled returning true
D/WifiService( 1246): ACTION_BATTERY_CHANGED pluggedType: 2
W/InputManagerService( 1246): Window already focused, ignoring focus gain of: co
[email protected]
I/ActivityManager( 1246): Starting activity: Intent { act=android.intent.action.
MAIN flg=0x10000000 cmp=com.android.contacts/.ContactsLaunchActivity }
I/dalvikvm( 1381): Jit: resizing JitTable from 512 to 1024
D/dalvikvm( 1381): GC_FOR_MALLOC freed 6812 objects / 361336 bytes in 99ms
I/ActivityManager( 1246): Displayed activity com.android.contacts/.ContactsLaunc
hActivity: 633 ms (total 633 ms)
E/dhcpcd ( 1480): timed out
I/WifiStateTracker( 1246): DhcpHandler: DHCP request failed: DHCP result was fai
led
I/dun_service( 1158): process rmnet event
I/wpa_supplicant( 1376): CTRL-EVENT-STATE-CHANGE id=0 state=8
I/wpa_supplicant( 1376): CTRL-EVENT-DISCONNECTED - Disconnect event - remove key
s
I/wpa_supplicant( 1376): CTRL-EVENT-STATE-CHANGE id=-1 state=8
V/WifiMonitor( 1246): Event [CTRL-EVENT-STATE-CHANGE id=0 state=8]
V/WifiMonitor( 1246): Event [CTRL-EVENT-DISCONNECTED - Disconnect event - remove
keys]
V/WifiMonitor( 1246): Event [CTRL-EVENT-STATE-CHANGE id=-1 state=8]
V/WifiStateTracker( 1246): Changing supplicant state: COMPLETED ==> DORMANT
D/WifiStateTracker( 1246): Reset connections and stopping DHCP
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
W/KeyCharacterMap( 1381): No keyboard for id 0
W/KeyCharacterMap( 1381): Using default keymap: /system/usr/keychars/qwerty.kcm.
bin
W/AudioFlinger( 1153): write blocked for 209 msecs, 1 delayed writes, thread 0xb
b18
D/WifiStateTracker( 1246): Disabling interface
D/NetworkStateTracker( 1246): setDetailed state, old =OBTAINING_IPADDR and new s
tate=FAILED
V/WifiStateTracker( 1246): New network state is DISCONNECTED
V/WifiStateTracker( 1246): Changing supplicant state: DORMANT ==> DORMANT
D/ConnectivityService( 1246): ConnectivityChange for WIFI: DISCONNECTED/FAILED
V/ConnectivityService( 1246): Attempt to connect to WIFI failed.
D/ConnectivityService( 1246): getMobileDataEnabled returning true
D/DataConnectionTracker( 1377): enableApnType(default), isApnTypeActive = false
and state = IDLE
D/DataConnectionTracker( 1377): type not available
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
D/Tethering( 1246): Tethering got CONNECTIVITY_ACTION
D/Tethering( 1246): MasterInitialState.processMessage what=3
E/HierarchicalStateMachine( 1246): TetherMaster - unhandledMessage: msg.what=3
I/GTalkService( 1425): [ServiceAutoStarter] --- connectivity changed
I/GTalkService( 1425): [ServiceAutoStarter] --- start GTalk service ---
I/MediaUploader( 1687): No need to wake up
D/GpsLocationProvider( 1246): updateNetworkState unavailable info: NetworkInfo:
type: WIFI[], state: DISCONNECTED/FAILED, reason: (unspecified), extra: (none),
roaming: false, failover: false, isAvailable: true
D/GTalkService( 1425): [GTalkService.1] ### onCreate ###
D/GTalkService( 1425): [GTalkService.1] setBackgroundDataWithLock: mBackgroundDa
taEnabled=true
D/GTalkService( 1425): [GTalkService.1] onStartCommand: found 0 connections, for
ce audit connections...
D/GoogleLoginService( 1425): onBind: Intent { act=android.accounts.AccountAuthen
ticator cmp=com.google.android.gsf/.loginservice.GoogleLoginService }
W/GoogleLoginService( 1425): Device has no accounts: sending Intent { act=com.go
ogle.android.gsf.LOGIN_ACCOUNTS_MISSING }
D/GTalkService( 1425): [GTalkService.15] account missing
D/GTalkService( 1425): [GTalkService.16] account missing
I/dun_service( 1158): process rmnet event
I/wpa_supplicant( 1376): wpa_driver_priv_driver_cmd failed_
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
D/Sensors ( 1246): sPending
D/Sensors ( 1246): sPending
I/wpa_supplicant( 1376): CTRL-EVENT-STATE-CHANGE id=-1 state=2
V/WifiMonitor( 1246): Event [CTRL-EVENT-STATE-CHANGE id=-1 state=2]
V/WifiStateTracker( 1246): Changing supplicant state: DORMANT ==> SCANNING
D/NetworkStateTracker( 1246): setDetailed state, old =FAILED and new state=SCANN
ING
D/ConnectivityService( 1246): Dropping ConnectivityChange for WIFI: DISCONNECTED
/SCANNING
D/Sensors ( 1246): sPending
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
I/wpa_supplicant( 1376): CTRL-EVENT-SCAN-RESULTS Ready
I/wpa_supplicant( 1376): Trying to associate with 00:23:69:c0:ce:a6 (SSID='APG'
freq=2422 MHz)
I/wpa_supplicant( 1376): CTRL-EVENT-STATE-CHANGE id=-1 state=3
I/dun_service( 1158): process rmnet event
V/WifiMonitor( 1246): Event [Trying to associate with 00:23:69:c0:ce:a6 (SSID='A
PG' freq=2422 MHz)]
V/WifiMonitor( 1246): Event [CTRL-EVENT-STATE-CHANGE id=-1 state=3]
V/WifiStateTracker( 1246): Changing supplicant state: SCANNING ==> ASSOCIATING
D/NetworkStateTracker( 1246): setDetailed state, old =SCANNING and new state=CON
NECTING
D/ConnectivityService( 1246): ConnectivityChange for WIFI: CONNECTING/CONNECTING
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
D/Sensors ( 1246): sPending
D/Sensors ( 1246): sPending
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
I/wpa_supplicant( 1376): CTRL-EVENT-STATE-CHANGE id=0 state=4
V/WifiMonitor( 1246): Event [CTRL-EVENT-STATE-CHANGE id=0 state=4]
V/WifiStateTracker( 1246): Changing supplicant state: ASSOCIATING ==> ASSOCIATED
D/NetworkStateTracker( 1246): setDetailed state, old =CONNECTING and new state=C
ONNECTING
I/wpa_supplicant( 1376): Associated with 00:23:69:c0:ce:a6
I/wpa_supplicant( 1376): CTRL-EVENT-STATE-CHANGE id=0 state=7
I/wpa_supplicant( 1376): CTRL-EVENT-CONNECTED - Connection to 00:23:69:c0:ce:a6
completed (reauth) [id=0 id_str=]
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
V/WifiMonitor( 1246): Event [Associated with 00:23:69:c0:ce:a6]
V/WifiMonitor( 1246): Event [CTRL-EVENT-STATE-CHANGE id=0 state=7]
V/WifiMonitor( 1246): Event [CTRL-EVENT-CONNECTED - Connection to 00:23:69:c0:ce
:a6 completed (reauth) [id=0 id_str=]]
V/WifiStateTracker( 1246): Changing supplicant state: ASSOCIATED ==> COMPLETED
V/WifiStateTracker( 1246): New network state is CONNECTED
D/NetworkStateTracker( 1246): setDetailed state, old =CONNECTING and new state=O
BTAINING_IPADDR
D/ConnectivityService( 1246): Dropping ConnectivityChange for WIFI: CONNECTING/O
BTAINING_IPADDR
D/WifiStateTracker( 1246): DhcpHandler: DHCP request started
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
I/dun_service( 1158): process rmnet event
I/dun_service( 1158): rstate == DUN_RMNETSTATE_ERROR in dun_monitor_kevents
D/Sensors ( 1246): sPending
D/Sensors ( 1246): sPending
I/ActivityManager( 1246): Starting activity: Intent { act=android.intent.action.
CALL_PRIVILEGED dat=tel:665570477 flg=0x10000000 cmp=com.android.phone/.Privileg
edOutgoingCallBroadcaster }
V/OutgoingCallBroadcaster( 1377): onCreate: this = com.android.phone.OutgoingCal
[email protected], icicle = null
V/OutgoingCallBroadcaster( 1377): - getIntent() = Intent { act=android.intent.a
ction.CALL_PRIVILEGED dat=tel:665570477 flg=0x10000000 cmp=com.android.phone/.Pr
ivilegedOutgoingCallBroadcaster }
V/OutgoingCallBroadcaster( 1377): - configuration = { scale=1.0 imsi=260/6 loc=
pl_PL touch=3 keys=2/1/2 nav=1/1 orien=1 layout=18 uiMode=17 seq=3}
D/PhoneApp( 1377): pulse screen lock
D/PhoneUtils( 1377): checkAndCopyPhoneProviderExtras: some or all extras are mis
sing.
V/OutgoingCallBroadcaster( 1377): Broadcasting intent Intent { act=android.inten
t.action.NEW_OUTGOING_CALL (has extras) }.
V/OutgoingCallReceiver( 1377): doReceive: Intent { act=android.intent.action.NEW
_OUTGOING_CALL (has extras) }
V/OutgoingCallReceiver( 1377): CALL to 665570477 proceeding.
D/PhoneUtils( 1377): checkAndCopyPhoneProviderExtras: some or all extras are mis
sing.
V/OutgoingCallReceiver( 1377): doReceive(): calling startActivity: Intent { act=
android.intent.action.CALL dat=tel:665570477 flg=0x10000000 cmp=com.android.phon
e/.InCallScreen (has extras) }
I/ActivityManager( 1246): Starting activity: Intent { act=android.intent.action.
CALL dat=tel:665570477 flg=0x10000000 cmp=com.android.phone/.InCallScreen (has e
xtras) }
D/InCallScreen( 1377): onCreate()... this = [email protected]
fe98
W/ResourceType( 1377): getEntry failing because entryIndex 65 is beyond type ent
ryCount 1
D/InCallScreen( 1377): initInCallTouchUi()...
D/ManageConferenceUtils( 1377): ManageConferenceUtils constructor...
D/InCallScreen( 1377): - Full touch device! Found dialerView: com.android.phone
[email protected]
D/InCallScreen( 1377): onCreate(): this is our very first launch, checking inten
t...
D/InCallScreen( 1377): internalResolveIntent: action=android.intent.action.CALL
I/AudioService( 1246): AudioFocus requestAudioFocus() from AudioFocus_For_Phon
e_Ring_And_Calls
D/AudioHardwareInterface( 1153): setMode(IN_CALL)
D/AudioFlinger( 1153): setParameters(): io 1, keyvalue routing=1, tid 1222, call
ing tid 1153
I/AudioHardwareMSM72XX( 1153): Routing audio to Handset
D/AudioHardwareMSM72XX( 1153): rpc_snd_set_device(0, 0, 0)
I/AudioFlinger( 1153): setFmVolume 73
D/InCallScreen( 1377): onCreate(): mInCallInitialStatus = SUCCESS
D/InCallScreen( 1377): onCreate(): exit
D/InCallScreen( 1377): onResume()...
D/PhoneApp( 1377): disable status bar
D/PhoneApp( 1377): StatusBarManager.DISABLE_EXPAND
D/StatusBar( 1246): DISABLE_EXPAND: yes
D/InCallScreen( 1377): - onResume: initial status = SUCCESS
D/InCallScreen( 1377): setInCallScreenMode: NORMAL
W/BluetoothHeadset( 1377): Proxy not attached to service
D/InCallScreen( 1377): syncWithPhoneState()...
D/PhoneUtils( 1377): dumpCallState():
D/PhoneUtils( 1377): - Phone: Handler{2fa7c738}, name = GSM, state = OFFHOOK
D/PhoneUtils( 1377): - FG call: DIALING isAlive true isRinging false isDialing
true isIdle false hasConnections true
D/PhoneUtils( 1377): - BG call: IDLE isAlive false isRinging false isDialing f
alse isIdle true hasConnections false
D/PhoneUtils( 1377): - RINGING call: IDLE isAlive false isRinging false isDial
ing false isIdle true hasConnections false
D/PhoneUtils( 1377): - hasRingingCall false hasActiveCall true hasHoldingCall
false allLinesTaken false
D/PhoneUtils( 1377): - Ringer state: false
D/InCallScreen( 1377): updateScreen()...
D/InCallScreen( 1377): - updateScreen: updating the in-call UI...
D/dalvikvm( 1377): GC_FOR_MALLOC freed 5875 objects / 339272 bytes in 76ms
W/BluetoothHeadset( 1377): Proxy not attached to service
I/power ( 1246): *** set_screen_state 1
D/PhoneApp( 1377): updateWakeState: callscreen true, dialer false, speaker false
...
D/PhoneApp( 1377): updateWakeState: keepScreenOn = true (isRinging false, isDial
ing true, showingDisc false)
D/CallNotifier( 1377): stopRing()... (OFFHOOK state)
D/Ringer ( 1377): stopRing()...
D/Ringer ( 1377): - stopRing: null mRingHandler!
D/InCallScreen( 1377): onPhoneStateChanged()...
D/InCallScreen( 1377): updateScreen()...
D/InCallScreen( 1377): - updateScreen: updating the in-call UI...
D/PhoneApp( 1377): updateWakeState: callscreen true, dialer false, speaker false
...
D/PhoneApp( 1377): updateWakeState: keepScreenOn = true (isRinging false, isDial
ing true, showingDisc false)
D/CallNotifier( 1377): stopRing()... (OFFHOOK state)
D/Ringer ( 1377): stopRing()...
D/Ringer ( 1377): - stopRing: null mRingHandler!
D/InCallScreen( 1377): onPhoneStateChanged()...
D/InCallScreen( 1377): updateScreen()...
D/InCallScreen( 1377): - updateScreen: updating the in-call UI...
D/PhoneApp( 1377): updateWakeState: callscreen true, dialer false, speaker false
...
D/PhoneApp( 1377): updateWakeState: keepScreenOn = true (isRinging false, isDial
ing true, showingDisc false)
D/CallNotifier( 1377): stopRing()... (OFFHOOK state)
D/Ringer ( 1377): stopRing()...
D/Ringer ( 1377): - stopRing: null mRingHandler!
D/InCallScreen( 1377): onPhoneStateChanged()...
D/InCallScreen( 1377): updateScreen()...
D/InCallScreen( 1377): - updateScreen: updating the in-call UI...
D/PhoneApp( 1377): updateWakeState: callscreen true, dialer false, speaker false
...
D/PhoneApp( 1377): updateWakeState: keepScreenOn = true (isRinging false, isDial
ing true, showingDisc false)
W/IInputConnectionWrapper( 1381): showStatusIcon on inactive InputConnection
I/ActivityManager( 1246): Displayed activity com.android.phone/.InCallScreen: 94
0 ms (total 1014 ms)
D/InCallScreen( 1377): handleOnscreenButtonClick(id 2131099758)...
D/InCallScreen( 1377): internalHangup()...
I/dalvikvm( 1377): Jit: resizing JitTable from 512 to 1024
D/CallNotifier( 1377): stopRing()... (OFFHOOK state)
D/Ringer ( 1377): stopRing()...
D/Ringer ( 1377): - stopRing: null mRingHandler!
D/InCallScreen( 1377): onPhoneStateChanged()...
D/InCallScreen( 1377): updateScreen()...
D/InCallScreen( 1377): - updateScreen: updating the in-call UI...
D/PhoneApp( 1377): updateWakeState: callscreen true, dialer false, speaker false
...
D/PhoneApp( 1377): updateWakeState: keepScreenOn = true (isRinging false, isDial
ing false, showingDisc true)
D/InCallScreen( 1377): handleOnscreenButtonClick(id 2131099758)...
D/InCallScreen( 1377): internalHangup()...
Devs, help me, bcos I can't fix this

Categories

Resources